Scheduled for March 28, 2026 at 3:00 AM – 3:15 AM
Affects
Currencies
Under maintenance from 3:00 AM to 3:15 AM
EGP
Under maintenance from 3:00 AM to 3:15 AM
Completed
March 28, 2026 at 3:15 AMCompleted
March 28, 2026 at 3:15 AMMaintenance has completed successfully
In progress
March 28, 2026 at 3:00 AMIn progress
March 28, 2026 at 3:00 AMMaintenance is now in progress
Planned
March 28, 2026 at 3:00 AMPlanned
March 28, 2026 at 3:00 AMDear Esteemed Clients,
We want to inform you that some of the National Bank of Egypt services will be unstable during the following times:
Saturday 28/3/2026 from 05:00 AM to 05:15 AM (Cairo local time)
There will be a system upgrade during this time
Thank you for your understanding