Scheduled for May 10, 2026 at 1:00 AM – 3:00 AM
Affects
Currencies
Under maintenance from 1:00 AM to 3:00 AM
EGP
Under maintenance from 1:00 AM to 3:00 AM
Completed
May 10, 2026 at 3:00 AMCompleted
May 10, 2026 at 3:00 AMMaintenance has completed successfully
In progress
May 10, 2026 at 1:00 AMIn progress
May 10, 2026 at 1:00 AMMaintenance is now in progress
Planned
May 10, 2026 at 1:00 AMPlanned
May 10, 2026 at 1:00 AMHello Valued Clients,
Please be informed that a planned maintenance window on the Egypt national switch is scheduled, and this may impact Pay-in and Payout services during the following period:
Date: Sunday, May 10, 2026
Time: 02:00 AM – 04:00 AM (GMT+1)
Purpose: Technical Maintenance
Impact: Pay-in and Payout channels may experience instability during this time.
We appreciate your understanding and cooperation.
Best regards.