Scheduled for May 10, 2026 at 11:00 PM – May 11, 2026 at 3:00 AM
Affects
Currencies
Under maintenance from 11:00 PM to 3:00 AM
EGP
Under maintenance from 11:00 PM to 3:00 AM
Completed
May 11, 2026 at 3:00 AMCompleted
May 11, 2026 at 3:00 AMMaintenance has completed successfully
In progress
May 10, 2026 at 11:00 PMIn progress
May 10, 2026 at 11:00 PMMaintenance is now in progress
Planned
May 10, 2026 at 11:00 PMPlanned
May 10, 2026 at 11:00 PMDear Esteemed Client,
Please be informed that there will be a planned maintenance window on the national switch, which will affect Wallet services during the period identified below:
Details:
Date: Monday, May 11, 2026
Time: 12:00 AM – 04:00 AM (GMT+1)
Purpose: Technical Maintenance
Impact: Wallet services will be unstable during this period.
We appreciate your understanding and cooperation.
Thank you.