TELECEL GHANA SYSTEM MAINTENANCE
Scheduled for May 13, 2026 at 11:00 PM – May 14, 2026 at 5:00 AM
Affects
Currencies
Under maintenance from 11:00 PM to 5:00 AM
GHS
Under maintenance from 11:00 PM to 5:00 AM
Completed
May 14, 2026 at 5:00 AMCompleted
May 14, 2026 at 5:00 AMMaintenance has completed successfully
In progress
May 13, 2026 at 11:00 PMIn progress
May 13, 2026 at 11:00 PMMaintenance is now in progress
Planned
May 13, 2026 at 11:00 PMPlanned
May 13, 2026 at 11:00 PMDear Esteemed Clients,
Please be informed that Telecel GHANA will be undertaking an emergency maintenance activity.
Kindly find the details of the activity below:
Activity Date 14th May 2026
Activity Duration: 6 hours
Start Time: 12:00 AM GMT+1
End Time: 06:00 AM GMT+1
Expected Downtime: 60 minutes.
Services to be Impacted: Telecel Cash Services
We will share updates as we receive them.
Thank you for your understanding.
Best regards.