Kora - EGP Payout Delays – Incident details

All systems operational

EGP Payout Delays

Resolved
Major outage
Started about 2 months agoLasted 10 days

Affected

Currencies

Major outage from 8:58 PM to 8:21 PM

EGP

Major outage from 8:58 PM to 8:21 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Dear Valued Clients,

    We are aware of delays affecting EGP processing payout . Please be assured that our team is working to restore normal service as a priority.

    We are monitoring the situation closely and will provide an update as soon as the issue is resolved.

    We apologise for the inconvenience and appreciate your patience.

    Best regards,