Scheduled for April 24, 2026 at 10:00 PM – April 25, 2026 at 3:00 AM
Affects
Currencies
Under maintenance from 10:00 PM to 3:00 AM
GHS
Under maintenance from 10:00 PM to 3:00 AM
Completed
April 25, 2026 at 3:00 AMCompleted
April 25, 2026 at 3:00 AMMaintenance has completed successfully
In progress
April 24, 2026 at 10:00 PMIn progress
April 24, 2026 at 10:00 PMMaintenance is now in progress
Planned
April 24, 2026 at 10:00 PMPlanned
April 24, 2026 at 10:00 PMDear Esteemed Clients,
Please be informed that Airtel Ghana (AirtelTigo) will be undertaking a maintenance activity on their debit and credit transactions on Saturday, April 25th, 2026.
Please note that AT Money services will not be available, or you may experience service disruptions during this period.
Kindly find the details of the activity below:
Activity Date: 25th April, 2026
Start Time: 12:00 AM GMT
End Time: 5:00 AM GMT
Activity Duration: 5 hours
Services to be Impacted: AT Money Services (Airtime & Debit and Credit Transactions)
We will share updates as we receive them.
Thank you for your understanding.